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About this Guide
With the X-Author Contracts for Cloud User Guide, you can find out how Apttus X-Author Contracts for 
Cloud works and how to manage your organization's and your customers' contracts.

Topic Description

What's Covered This guide walks the X-Author Contracts for Cloud user through an entire contract lifecycle 
inside Microsoft Word while complying with approval workflows and using the latest terms 
and clauses from your legal playbook. It covers step-by-step instructions, and use cases for 
the features provided by X-Author for Contracts for Cloud.

Primary Audience Individuals who are working on any aspect of contracts: contract managers, contract 
creators, contract negotiators, and contract reviewers

IT Environment Refer to the latest X-Author Contracts for Cloud on Salesforce Release Notes for information 
on System Requirements and Supported Platforms.

Updates For a comprehensive list of updates to this guide for each release, see
the What's New topic.

Other Resources • Contract Management Admin Guide: Refer to this guide for installing and setting-up 
Contract Management in your organization.

• Contract Management User Guide: Refer to this guide to set-up the entire contract 
management process.

This guide describes the following tasks: 

• Creating a template
• Managing templates
• Creating offline agreements
• Using playbook
• Marking clauses and fields
• Using template expression builder
• Updating fields from Contract Management

Before using X-Author Contracts for Cloud, you must be familiar with the following:

• Basic Salesforce administration
• Microsoft Word
• Apttus terms and definitions
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What's New
The following table lists changes in the documentation to support each release.

Release Topic Description

Spring 2019 Preview Reconciliation New topic. A new feature for this release.

Hiding or Showing Smart Boundaries New topic. A new feature for this release.

Inserting Fields in a Template as a Table New topic. A new feature for this release.

Inserting Fields in a Template as a 
Section

New topic. A new feature for this release.

Setting Segments in Templates New topic. A new feature for this release.

Winter 2018 Making Fields Read Only in a Template New topic. A new feature for this release.

Refreshing Clauses in a Template New topic. A new feature for this release.

Opening an Agreement Document Modified topic. This topic is updated to 
add information about the number of 
agreements displayed on logging in.

Summer 2018 Template Expression Builder New topic. A new feature for this release.

Setting Conditional Segments in 
Templates

New topic. A new feature for this release.

Deleting Smart Elements New topic. A new feature for this release.

Promoting Clauses New topic. A new feature for this release.

Inserting Inline Clauses Modified topic. This topic is updated to 
add information about the new inline 
clauses feature.

Tracking Clause Activity New topic. This topic is added for 
enhancement to Clause Tracking feature.

Making Clauses Condition-based New topic. A new feature for this release, 
as part of the Template Expression Builder
feature.

https://documentation.apttus.com/display/XACSFWIN18UG/Refreshing+Clauses+in+an+Agreement+Template
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Release Topic Description

About Template Clauses Renamed to About Template Clauses 
Menu.
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About X-Author Contracts for Cloud
Apttus X-Author Contracts Cloud gives contract administrators and legal teams full access to powerful 
contract negotiation tools inside Salesforce CRM. Log in to Apttus Contract Lifecycle Management (CLM) 
directly from Microsoft Word, check out your contract template or agreement document and make 
changes using Word's native features. You can use the X-Author add-in to check-in your document, 
reconcile clauses, fields and other contract elements in an easy-to-use interface. Negotiating parties can 
insert and modify contract terms and clauses and add non-legal language, then check in redlined, clean 
and final versions back to the agreement record. Advanced reconciliation capability also allows users to 
reconcile any terms or clauses that may have changed during the approval process and update them in the 
Apttus Contract Management directly. Apttus Contract Management Document Versioning integrates with 
X-Author, meaning document versions can be tracked with ease. Furthermore, users who are already 
familiar with Microsoft Word will also be comfortable using X-Author, as many Word capabilities such as 
the tracking of changes and commenting are already a part of the tool.
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Getting Started
The X-Author Contracts for Cloud Add-In is designed for contract administrators and/or legal users to help 
streamline the process of creating and maintaining contracts and associated contract and clause 
templates. Using X-Author Contracts for Cloud, contract administrators can manage complex negotiation 
cycles with clause and contract templates easily. The X-Author Contracts for Cloud Add-In is not a 
required component, but adds tremendous value to the contract administrator by leveraging the power of 
Apttus within Microsoft Word.

The X-Author Contracts for Cloud Add-In provides support for versioning of agreements, where contract 
administrators can save redlined, clean, and final versions of non-standard language in a Microsoft Word 
document opened either from Salesforce or locally. When saving final versions, the X-Author Contracts for 
Cloud Add-In also helps the user to reconcile any terms that might have changed during the approval 
process. Contract and Clause templates can also be managed, including the ability to insert, save as, and 
replace them to and from Apttus. Finally, users can compare versions of a contract.

The X-Author Contracts for Cloud Add-In also provides support for creating conditional text within a 
contract or clause template. This allows contract administrators to create sophisticated conditional clauses 
that can include or exclude certain text or clauses depending on how a conditional expression containing 
valid agreement related merge fields or FX2 fields are evaluated.

This section covers:

• Installing X-Author Contracts
• Installing X-Author Contracts Without an Installer
• Logging in to X-Author Contracts

Installing X-Author Contracts
X-Author for Contracts Cloud is a Microsoft Word add-in that requires a package installer. Alternatively, 
your DevOps team may also provide you an X-Author Contracts manifest file which you can configure or 
install in your Mac system to start using X-Author Contracts. This section would describe how to install X-
Author Contracts on your Mac system using both the installer or the manifest file.

System Requirements

Your computer must meet the minimum requirements listed below to use X-Author Contracts for Cloud.

Supported Component Minimum Supported Version

Mac OS El Capitan version 10.11.3

Mac OS High Sierra version 10.13.3

Microsoft Office Microsoft Word 2016 for Mac, version 15.41 or later

Microsoft Office 365 Online or Cloud applications do not support plugins.
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To install the X-Author Contracts add-in

1. Download the X-Author Contracts for Mac pkg file using the link provided by your Apttus 
representative.

2. Double-click the pkg file (right-click and Open if file is untrusted). 

3. Follow the installation instructions to complete installation.

4. Quit any open instances of Microsoft Word.
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To configure the manifest file in your system

1. Download the manifest file provided by your DevOps team.
2. Copy the manifest XML file and paste it in the following folder location: ~/Library/Containers/

com.microsoft.Word/Data/Documents/wef
3. Close the Microsoft Word application on your system (if open) and open it again.
4. In Microsoft Word, go to Insert > My add-in.

You will now see X-Author Contracts add-in.

To launch the X-Author Contracts add-in

1. Open Microsoft Word.
2. Go to Insert > My Add-ins.

3. Choose X-Author Contracts from the list of add-ins displayed in the drop-down. Apttus X-Author 
loads in a new pane to the right of the document window.

Installing X-Author Contracts Without an Installer
This is an alternate method of installing X-Author Contracts for Cloud. If you have an X-Author Contracts 
for Cloud installer, you do not need to perform the steps described under this topic. You need to perform 
these steps only if you do not have an installer file and you need to create an XML manifest file.

This is an alternate method of installing X-Author Contracts for Cloud. If you have an X-Author 
Contracts for Cloud installer, you do not need to perform the steps described under this topic. You 
need to perform these steps only if you do not have an installer file and your Apttus representative 
has shared only the XML manifest file with you.



Don't confuse the Microsoft Word Insert option with the Mac menu bar Insert option. Going 
to Mac Menu bar > Add-ins > My Add-ins does not list the Apttus X-Author add-in.
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To create an XML manifest file:

1. Open a text editor such as Notepad.
2. Copy the following lines and paste them into the text editor:

<?xml version="1.0" encoding="UTF-8"?>
<!--Created:cb85b80c-f585-40ff-8bfc-12ff4d0e34a9-->
<OfficeApp xmlns="http://schemas.microsoft.com/office/appforoffice/1.1" 
           xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
           xmlns:bt="http://schemas.microsoft.com/office/officeappbasictypes/1.0"
           xmlns:ov="http://schemas.microsoft.com/office/
taskpaneappversionoverrides"
           xsi:type="TaskPaneApp">
  <Id>f28a4a81-39b5-4fe7-8806-c8505c24d311</Id>
  <Version>1.0.228.2017</Version>
  <ProviderName>Apttus Corporation</ProviderName>
  <DefaultLocale>en-US</DefaultLocale>
  <DisplayName DefaultValue="X-Author Contracts" />
  <Description DefaultValue="X Author Contracts"/>
  <IconUrl DefaultValue="https://XAJS_HOSTNAME/ui/xajs/Images/icon_32x32.png" />
  <HighResolutionIconUrl DefaultValue="https://XAJS_HOSTNAME/ui/xajs/Images/
icon_64x64.png" />
  <SupportUrl DefaultValue="https://www.apttus.com" />
 <AppDomains>
    <AppDomain>https://XAJS_HOSTNAME</AppDomain>       
  </AppDomains>
  <Hosts>
    <Host Name="Document" />
     </Hosts>
  <DefaultSettings>
    <SourceLocation DefaultValue="https://XAJS_HOSTNAME/ui/xajs/App/index.html" />
  </DefaultSettings>
  <Permissions>ReadWriteDocument</Permissions> 
</OfficeApp>

3. Replace XAJS_HOSTNAME with your hostname.

4. For Multi-Tenant Environment OR Salesforce Platform:
a. Add the following app domain in the app domains section, if it is not in manifest XML.

Contact your implementation Or CloudOps team to obtain XAJS_HOSTNAME.
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<AppDomains>
<AppDomain>https://test.salesforce.com</AppDomain>
<AppDomain>https://login.salesforce.com</AppDomain>    
<AppDomain>https://xajs.apttuscloud.com</AppDomain>    
</AppDomains>

5. Select File > Save As. 
b. In the Save as type dropdown list, select All Types. 
c. In the Filename text box type the filename including the .xml extension.

6. Copy the manifest XML file and paste it in the following folder location in mac: 
~/Library/Containers/com.microsoft.Word/Data/Documents/wef

7. Close the Microsoft Word application on your system (if open) and open it again.
8. In Microsoft Word, go to Insert > My add-in > X-Author Contracts.

Logging in to X-Author Contracts
Before you can work with your agreement documents in X-Author, you must log in to Apttus CLM through 
the add-in.

To log in to X-Author Contracts

1. Launch Microsoft Word. Open a new document or the document you want to work with.
2. Launch the X-Author add-in as described in Installing X-Author Contracts.
3. After the X-Author add-in pane loads, click the menu icon   on the left-hand side to display the 

Manage Connections option, if you are logging in for the first time. If it is your subsequent login, 
select the connection name from the left hand menu to login.

4. In the Manage Connections screen, enter:
a. Connection Name: Enter the connection name for your connection.
b. Host Name: Enter the host URL for your instance of Apttus CLM and click Save. For 

Salesforce environments, use either https://login-sfdc.apttuscloud.com (production) or 
https://test-sfdc.apttuscloud.com (sandbox). This redirects you to the Sign-in page.  

5. If it is the first time you are logging into CLM from the add-in, you may be prompted to allow access 
to X-Author. Click Allow to proceed.

6. Enter your host credentials (email and password) and click Sign In.

After successful login, the X-Author pane refreshes to display the agreement documents list.

https://login-sfdc.apttuscloud.com
https://test-sfdc.apttuscloud.com
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Working with Agreements
After you have checked out your document, you are ready to begin the negotiation and redlining process. 

The following sections describe the features you can use in X-Author when working with agreement 
documents.

• Opening an Agreement Document
• Using Playbook
• Doc Clauses
• Doc Fields
• Checking in an Agreement Document
• Updating Fields from Contract Management
• Opening Agreements in Contract Management
• Creating Offline Agreements
• Importing Offline Agreements
• Tracking Clauses in your Agreement Document

Opening an Agreement Document
To work with any version of an agreement document associated with an agreement record in CRM, you 
must open it directly in X-Author Contracts. There are three common ways for you to open a document, 
depending on how you are accessing the document itself. Open your DOCX agreement document using 
one of the following methods:

• Open the document directly from Microsoft Word.
• Download the document directly from the Apttus CLM record and open it using Microsoft Word.
• Download the document from an email attachment (e.g., Outlook).

After opening a document, only one person can work on the document at a time.

The agreement list has two options for opening an agreement: Open, and Open And Update. The 
difference between the two options is that when you select Open and Update, you can update the values 
of the fields in your agreement document from the CLM agreement record.

To open an agreement document

1. Open Microsoft Word and choose a blank document.

If you are using X-Author Contracts for Cloud on MacBook Air, you might see an error message 
related to “Add-in memory usage” when you work with a document of size 2 MB or more. This is 
due to a limitation of Microsoft Word. You can continue working after closing this warning 
message. However, to avoid high memory usage related issues, Apttus recommends that you 
close any unused applications on your system while working with X-Author Contracts for Cloud.
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2. Go to Insert > My Add-ins > X-Author Contracts. Log in to X-Author Contracts.
3. From the X-Author Contracts add-in pane in Microsoft Word, click menu icon   and select X-

Author Contracts options to open X-Author Contracts pane.
4. In the X-Author Contracts pane, go to Start tab > Search > Search Agreements.

5. Enter the agreement name or number as the search term and click the search icon.
6. From the search results, click the expand icon of the agreement you want to download. In the 

expanded description, click Documents. This opens the Agreement Details page.
7. The Agreement Details page lists all the versions of the document. To open a version, click the more 

icon   next to the version and click Open. Your document is downloaded.
8. Open the downloaded document in Microsoft Word. The document is automatically opened and 

locked by you (You'll see a message saying 'Document is locked by you'). This means that your 
agreement is opened.

To open and update an agreement document

1. From the X-Author Contracts add-in pane in Microsoft Word, click menu icon  and click X-Author 
Contracts.

2. In the X-Author Contracts pane, go to Start tab > Search > Search Agreements.
3. Enter the agreement name or number as the search term and click the search icon.
4. From the search results, click the expand icon of the agreement you want to download. In the 

expanded description, click Documents. This open the Agreement Details page.
5. The Agreement Details page lists all the versions of the document. To open and update a version, 

click more icon   next to the version and click Open And Update. The selected document is 
downloaded.

6. Open the downloaded document. You'll get a message saying 'Document is locked by you' and the 
X-Author Contracts pane directly opens the Update from CLM page. This page lists all the fields 
whose values have changed in the CLM record since the last Check-in.

7. You can view both the Current Value and the CLM Value of the fields. Click Update, to update the 
values of the listed fields with the latest values from the corresponding agreement record in CLM. If 

If you have already downloaded the document from another location, open the document in 
Word. The document is automatically locked by you (You'll see a message saying 
'Document is locked by you'). If the document is already opened by another user, you will 
not be able to work with it until it is checked in.



Maximum of 50 agreements are displayed in one instance in the X-Author Contracts pane. 
When you search agreements using filters, 20 agreements are displayed in one instance 
based on the search results and if you scroll further, 20 more agreements are displayed.



The automatic locking of your document is controlled by a Product Setting in Contract 
Management, EnableAutoCheckOut. The document is automatically locked on opening only if the 
value of EnableAutoCheckOut is set to True in Contract Management.
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you click Cancel, the agreement would simply open without updating the field values. 
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Locking and Unlocking Documents

When you open a document in X-Author Contracts, the document is locked for editing and cannot be 
checked out by anyone else. Anyone with proper permissions for the document's agreement record can 
still view and/or download the document, but they cannot make edits and check the document back in 

while you have it locked. You can always check the lock status of a document by clicking the   Lock 
Status button. This opens the Lock Status page with the following information:

• Agreement Name: Shows the name of the agreement.
• Document protection mode: Shows the protection level of the agreement document. The values 

could be Full Access, Insert Comment and Track Changes Only, Track Changes Only, Fill in form 
fields only and Read Only.

• Document locked by: Shows the name of the user who has locked the document. If the document is 
locked by another user, this field will show the name of the user who has locked the document.

• Locked date: Shows the date and time of locking.
• Release Lock or Acquire Lock: This is a  toggle button. If a document is already locked you can 

unlock it using the Release Lock. If you have accidentally unlocked a document, you can lock it again 
by clicking Acquire Lock.

• Refresh Lock: This button checks the lock status of your document. If your document is not locked 
by anyone, and you click Refresh Lock, the document is locked and you are redirected to the Work
tab of X-Author Contracts. You need to click Refresh Lock when you open a new document, to start 
editing it.

• Cancel: Takes you back to the previous screen that you were working on.

When you open an agreement document, depending on the product configuration, it is automatically 
locked. Locks can only be released when you either manually release the lock or check in the document. 
The automatic locking of your document is controlled by a Product Setting in Contract Management, 
EnableAutoCheckOut.

• If the value of EnableAutoCheckOut set to True, your agreement document is automatically locked 
when you open it in X-Author Contracts.

• If the value of EnableAutoCheckOut set to False, your agreement document is not automatically 
locked and the Work and Finish tabs are disabled for you. To start editing the document you have to 
first lock it using Refresh Lock.

To release a document lock

Before you can release a lock on a document, it must be opened in X-Author Contracts.

1. From the X-Author pane, click the Lock Status button. The Lock Status page shows agreement 
details and information on the current document lock.

2. Click Release Lock on the Lock Status page.

The document page refreshes and shows the Start tab of X-Author Contracts. You cannot access the 
Work and Finish tabs of X-Author Contracts after releasing the lock. When you click the Lock Status icon, 
the Acquire Lock button replaces the Release Lock button in the Lock Status page.
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Using Playbook
The Playbook allows you to access a library of previously defined clause templates in Apttus CLM for use 
with your document agreement type during negotiations. Instead of editing clauses already in the 
document or inserting static text, you can insert clauses from Playbook directly into the agreement 
document and track and manage changes to clause content as negotiations proceed. You can also use 
Playbook to mark text as clauses or fields, applying Apttus properties to these clauses and fields when the 
document is checked in and reconciled.

To use Playbook, go to Work tab in X-Author Contracts pane and select Playbook tab. You can use the 
Playbook to

• Insert inline clauses in the agreement document
• Insert smart clauses in the agreement document
• Mark document text as a clause
• Promote marked clauses to the Playbook

When a text is marked as a clause, the element becomes Smart. Smart clauses adopt Apttus properties 
and you can take various actions on the clause content, and reconcile them to reflect them in the 
associated agreement record.

For more explicit definitions of smart clauses and smart fields, see Working with Agreements.

Inserting Clauses

Playbook lists all clauses available for the specific agreement type associated with the document. Clause 
content typically includes only static text, but it can also contain smart fields, including header level and 
lookup merge fields. When you insert a clause that contains smart fields, field values are automatically 
populated with values from the associated agreement record in CLM. You can insert a clause from the 
Playbook into a document in two different ways, as described below.

• Inserting as an inline clause: An inline clause is a clause which does not have a content-control 
border around it. The inline clause contains static text and the content of the clause cannot be 
edited in an agreement document. Moreover, when you insert an inline clause it is not recorded in 
the Doc Clauses list and the clause reconciliation page. If you insert a clause containing smart fields 
as an inline clause, the values in the smart fields are converted to plain text and do not have a 
content-control border.

• Inserting as a smart clause: A smart clause is a clause with content-control border. A smart clause 
contains text that can be edited in an agreement document. When you insert a clause as smart, you 

If you released a document lock by mistake and want to continue working with the document, go 
to the Lock Status page and click Acquire Lock.



Unless explicitly stated, any mention in this guide of fields or clauses should be considered a 
reference to smart fields and clauses.
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can see it in the clause list of the Doc Clauses tab of X-Author Contracts. Additionally, when you 
make changes to the content of a smart clause, those changes are tracked through redlines and you 
can see the changes recorded on the clause reconciliation page.

To view the content of a clause listed in the Playbook panel, click the Clause Name. A section displaying 
the text of the clause is displayed below the clause list. Click the clause text to scroll.

To insert a clause

1. In the X-Author Contracts pane, go to Work > Playbook > Search Clauses.
2. In Search Clauses, click the search icon to list all the available clauses or enter a search string to 

search a specific clause. You can also click clause filter icon   to get filtering options. You can 
also filter your clause search based on clause Category, Subcategory, Locale, Language, and Type.

3. In the agreement document, place your cursor at the point of insertion.

4. Select the clause from the Playbook pane, click more icon  next to the clause name and click Insert 
to insert the clause as an inline clause (or non-smart clause) in your document.
OR

When you insert an agreement clause into a document, it is only valid for that specific agreement 
document.
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Select the clause from the Playbook pane, click more icon  next to the clause name and click Insert 
Smart to insert the clause as a smart clause in your document.

You get a success message and if you have selected Insert Smart, the inserted clause is marked as a 
smart clause (shown with a grey border). The text of the inserted clause appears redlined in the agreement 
document if the agreement's protection level is set to Insert Comments and Track Changes.

If you have inserted the clause as smart, you can go to Work tab > Doc Clauses to confirm that the clause 
is now recognized in the document. When you check in the document, any smart clauses can be 
reconciled to the agreement and information of the inserted clause is added to the Agreement Clause
related list on the agreement record.

To learn how the Agreement Clause related list is populated with each insert, modify and delete action, 
refer to the Apttus Contract Management Administrator Guide.

Marking Clauses in an Agreement

During the process of negotiation, you may find a section of text that you would like to mark as smart. Mark 
document content as a clause when:

• You are with a third party offline agreement created or imported into the agreement record that 
contains language which should be tagged as clauses.

• An external party adds language to the agreement document that constitutes a clause.

By marking this text as a clause in your agreement document, the text adopts the properties of the marked 
clause. You can even choose to replace text in the agreement with text from a pre-existing clause in your 
Playbook. When the agreement document is checked in and reconciled to the agreement record, 
information on marked clauses is added to the Agreement Clauses related list.

To mark a clause in an agreement

1. In the X-Author Contracts pane, go to Work > Playbook.
2. Highlight the content of the contract to be marked as a clause and click Mark New Clause in the 

Playbook tab.
3. In the Mark Clause form, specify the following fields for marking the clause. The clause will be 

automatically marked as a 1-off instance of the clause for this agreement.

Field Description

Clause Name Enter a new name for the clause.

Action By default, Inserted is chosen and is Read-Only.

Category Select a category for your clause.

Clauses can only be smart in the context of single generated or offline Apttus agreement 
document.
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Field Description

Sub Category Select a sub category for your clause. Options in the list will change based on the 
category you selected.

Exception Select a term exception record from the drop-down list to associate with your 
clause.

Risk Rating Select an appropriate risk rating for your clause. Valid values are:
• Green
• Red
• Yellow

Materially Significant Select this check box if you want to make your clause materially significant.

Clause Text 
(Selected)

This text area shows the selected text which you want to mark as a clause.

4. Click Save to apply Apttus clause properties to the highlighted content and mark the content as a 
smart clause. When you check in and reconcile your agreement document, the clause will be 
displayed as inserted in the Agreement Clauses related list and is listed in the Document panel 
under Clauses.

Your clause is succesfully marked and acquires content control border like the other smart clauses.

After inserting the clause, you can go to Work tab > Doc Clauses to confirm that the clause is now 
recognized in the document. When you check in the document, any smart clauses can be reconciled to the 
agreement and information of the inserted clause is added to the Agreement Clause related list on the 
agreement record.

Promoting Clauses to Playbook

You can promote a marked clause from an agreement to the playbook to make that clause a part of the 
Playbook's clause repository. When you mark a text as a clause in an agreement, the highlighted text 
acquires smartness and becomes a clause. However, a marked clause is only considered a clause for that 
agreement instance and when you regenerate the agreement, the marked clause is lost. If you want to 
reuse the same marked clause for that agreement record even after regenerating the document or want to 
make the marked clause available for other agreements and users, you can use Promote Clause to make it 
a part of the Playbook.

Pre-requisites

• You must have a marked clause in X-Author Contracts.

Scroll past the Clause Text to view additional fields and buttons required to mark the clause.

If you decide you want to unmark a clause during the same session in which you marked it, you 
must use the Doc Clauses tab to remove Apttus clause properties.
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To promote a clause to the Playbook

1. Go to Work tab > Promote Clauses. If you cannot see Promote Clauses under the Work tab, click 

the more icon   and from the menu, select Promote Clauses.
2. From the list of marked clauses, select the clause you want to promote to the clause library and click 

Promote Clause.
3. In the Promote Clause form, specify the following details,

Field Description

Clause Name Enter a new name of the clause.

Category Select a category for your clause. The values of the categories are 
defined by your admin and help in filtering the clauses.

Subcategory Select a sub category for your clause. Options in the list will change 
based on the category you selected.

Language Choose the default clause language.

Description Enter a new description or modify the existing description for the clause. 
Maximum of 255 characters (an error will be thrown if this limit is 
exceeded).

Guidance Enter new guidance or modify existing guidance to help users determine 
the purpose of the clause.

Keywords Enter comma-separated keywords to associate with the template. 
Keywords make it easier to search the templates.

4. Click Save.

Your have promoted the clause to the Playbook.  You can open the Playbook and search the promoted 
clause to use it in any other document or template.

Preview Reconciliation

The preview reconciliation feature allows you to preview and compare the changes in a generated 
document with the Contract Management values when you perform any of the following tasks.

• Modify a smart field
• Mark a field
• Modify a marked field
• Modify a smart clause
• Insert a clause
• Modify a marked clause
• Mark a clause for deletion
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To preview reconciliation

1. Go to Work tab > Preview Reconcile. If you do not see Preview Reconcile under the Work tab, click 

the more icon (
 and from the menu, select Preview Reconcile.
The Preview Reconcile tab displays all the modified smart fields, modified mark fields, and new 
marked fields. Review the CLM Value and Current Value of the changed smart fields in your 
document.

2. Click Next.

3. The Preview Reconcile tab displays the modified smart clauses, marked clauses, inserted clauses, 
and clauses marked for deletion. Expand a clause from the list to review 
the Original and Edited content of the clause.

4. Click Back to navigate to the previous screen.

Hiding or Showing Smart Boundaries

Smart fields and smart clauses in an agreement document are represented in Microsoft Word as a content 
control, with a bounding box. You can control the visibility of bounding boxes using the Hide Smart 
Boundary and Show Smart Boundary options.

Prerequisite

Ensure that the checked out document contains smart fields or clauses.

To hide smart boundaries in an agreement document

1. In the X-Author Contracts pane, go to Work tab and click the more icon ( ).
2. Click Hide Smart Boundary.

This hides all smart boundaries of smart fields and smart clauses.

To see smart boundaries in an agreement document

1. In the X-Author Contracts pane, go to Work tab and click the more icon ( ).
2. Click Show Smart Boundary.

This shows all smart boundaries of smart fields and smart clauses.

)

If you have only one change in the agreement document, the Cancel button is displayed 
instead of the Next button.



Regardless of the Hide/Show Boundary option selected before checking in, the boundaries 
are displayed after checking out the document.
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Doc Clauses
The Doc Clauses tab lists all smart clauses in the agreement document. You can take the following actions 
on clauses from the Doc Clauses tab:

• Navigate to a clause in the document
• Mark a clause for deletion
• Unmark a clause

To view a clause

1. Go to Work > Doc Clauses tab.
2. Click on a clause name in the list. The document scrolls to highlight the selected clause in the 

agreement document.

To mark a clause for deletion

1. Go to Doc Clauses > Available Clauses list.
2. Search the clause you want to delete or select the clause from the available clauses list and click 

the more icon   next to the clause name.
3. Click Delete.
4. You will get a confirmation message, select Delete again.

You'll get a message, "Your clause will be deleted on reconciliation" and the clause text in the document is 
marked with a strikethrough. You can click Undo Delete from the more options next to the clause name, to 
remove the mark at any time in the same session.

Check-in the document and choose Reconcile. The content of the deleted clause is removed from the 
document and a "Deleted" entry is recorded in the Agreement Clause related list on the agreement record 
in Salesforce.

Unmarking a Clause

Unmarking a clause removes Apttus clause properties and returns the text to a static state. If you decide 
you want to unmark a clause during the same session in which you marked it, you can use the Doc 

Sections and supporting documents do not display in the list of clauses if they contain a smart 
field.



For more information on tracking clauses and clause activity in your agreements, refer to the
Contract Management Administrator Guide for the Salesforce platform.
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Clauses pane to remove Apttus clause properties. Note that, if you chose to replace the text with a clause 
from the library, you cannot choose to unmark the clause, it can only be deleted.

Pre-requisites

• You must have marked static text in the agreement document as a clause in the same session using 
Playbook.

To unmark a clause

1. Go to Work > Doc Clauses.
2. Search the clause using Search Clauses or select the clause from the Available Clauses list.
3. Select the marked clause and click the more icon.
4. Click Unmark.

You will see a confirmation message and the clause will be removed from the available clauses list too. The 
clause will also lose the content control border after your Unmark it.

Doc Fields
The Fields section of the Document Panel lists all smart fields in the agreement document. Use the 
Document Panel to take the following actions on fields in the document:

• View and change field values in the document
• Mark Fields
• Reject changed field values
• Validate field values
• Mark fields for deletion

To view and change fields

1. Go to Work > Doc Fields tab. All fields are displayed in a list in the order they appear in the 
document. Previous (as of last check-in), CLM, and Current (document), values are displayed.

2. Click on a field in the list to snap to and highlight the field in the document.
3. To change the current value of a field, place your cursor in the field content control in the document 

and make changes. To view the updated field value in the Doc Fields list, click on some other tab 
and then click back on Doc Fields tab.

4. Click Validate to confirm that the new field value is valid for its corresponding data type.

Marking Fields

Using Doc Fields, you can mark small chunks of agreement document content as fields. When you mark 
content in an agreement document as a field, it becomes a smart field. Smart field values can be 

Changed field values are updated on in the agreement document upon check-in. If you choose to 
reconcile fields during check-in, they will also be changed on the agreement record.





X-Author Contracts for Cloud on Salesforce Spring 2019 User Guide

26 Copyright ©2011-2019 Apttus Corporation. All rights reserved.

reconciled with data in the agreement record when the document is checked in, allowing changes made 
during negotiation to be accurately reflected and managed as data in Apttus CLM. Content marked as a 
field must map to the data type of existing fields in your agreement record.

To mark a field in an agreement

1. Go to Work > Doc Fields.
2. Highlight the content of the contract to be marked as a field.
3. In the Doc Fields pane, click the more icon and select Mark Fields to open the Mark Fields form.
4. The Mark Fields form lists all the available CLM fields with their name and type that could be made 

smart. These fields are grouped into different categories according to the field type, like Information, 
Key Dates, Miscellaneous, etc.

5. Use Search Fields to enter the field name and search or scroll through the list of fields to select the 
field to be applied to the selected text.

6. Click the more icon next to the field name and click Mark Field. You will get a confirmation message.
7. Select Mark in the confirmation message to mark the selected text as a smart field.

You will get a success message and the selected text in the contract will acquire content control boundary. 
The content adopts the properties of the same field on the agreement record.

Rejecting changes to a field

If changes have been made to smart fields in the document, you can choose to reject these changes in the 
same session prior to check-in.

To reject changes

1. Go to Doc Fields > list of doc fields.
2. Click on more options on the changed fields in the Doc Fields pane and select Reject changes.

The field value is reverted to its previous value prior to the change. The Doc Fields pane reloads to show 
the change.

Marking a field in a single agreement does not mark the field across all other documents for the 
same agreement record.



Make sure the format of the text you are marking matches the data type you are mapping to. You 
will receive an error if the text is not valid for the field type you choose.
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Validating Fields

Use the Validate action to ensure that all smart fields in your document are in the proper format for their 
assigned data type (e.g., Date, Number, DateTime, selected values from picklists,etc.). The agreement 
document cannot be reconciled at check-in unless all fields in your document are valid.

To validate fields

1. Go to Doc Fields.
2. Click on the Validate button. If any fields are invalid, the field row in the Document pane will be 

highlighted in red.
3. Make any corrections to invalid fields as needed and click Validate again to confirm there are no 

invalid fields.

If all the fields are valid, you'll see a success message displayed at the top of the pane. You can now check 
in your document.

Marking Fields for Deletion

There will be times in the negotiation when a negotiating party wants to remove language from an 
agreement which contains a smart field. Depending on document protection settings, non-Apttus users 
can remove content from the agreement, but any smart field content removed will not remove the field 
itself. Follow the instructions on this page to mark fields for removal. You usually want to mark fields for 
removal when:

• An Apttus user marked static text as a field.
• A Template Admin marked a field as smart.
• You need to delete a smart clause from an agreement document.

To mark fields for deletion

1. Go to Document > Fields.
2. Right-click on a field and select Mark for Deletion.
3. Click Yes on the confirmation dialog that appears. The field is marked with a strikethrough in the 

document and the Document pane to denote that it has been marked for deletion. 
4. Check-in the document and choose Reconcile. The field is removed from the document.

To unmark fields for deletion

If you decide in the same session that you want to keep a field in the document that you have already 
marked for deletion, follow these steps.

1. Go to Document > Fields.
2. Right-click on the field in the Document pane that you marked for deletion and select Undo Delete.
3. Click Yes on the confirmation dialog that appears.
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Checking in an Agreement Document
Whether you are saving a redlined version, clean version, or final version, the process for each is similar 
and each makes use of X-Author's Check-In feature. Only Microsoft Word documents in DOCX format are 
supported for maintaining versions, opening and checking in agreement documents. When you check in 
from X-Author, the document you are working on is converted back to the same document format as when 
it was first checked out.

To check in an agreement document

1. From the X-Author Contracts pane, click Finish tab. The Check-in page is displayed.
2. From Save Options, choose one of three options for saving the document:

Option at 
Check-in

Description

With 
Redlines

This saves a draft version of the agreement document with all markups and Redlines is used 
as the action in your org's configured default document naming convention. A DOCX version 
of the document is saved in Notes & Attachments. If Contract Document versioning is 
enabled, selecting this option creates a Minor version under the Document Versions related 
list in your Agreement record.

Without 
Redlines

This saves a draft version of the document without markups and is typically done before 
sending an agreement to a third party for review. Track changes/redlines are automatically 
removed from the Word file and _Clean is used as the action in the configured default 
document naming convention. A DOCX version of the document is saved in Notes & 
Attachments. If Contract Document Versioning is enabled, selecting this option creates a 
Major version under the Document Versions related list in your Agreement record.

Final - to be 
signed

This saves a version of the document without markups and also enables a PDF version of 
the document to be created. If this option is selected, a PDF file will be saved to the 
agreement's Notes & Attachments related list. By default, _Final is used as the action in the 
configured default document naming convention. If Contract Document Versioning is 
enabled, selecting this option creates a Major version (DOCX) under the Document 
Versions related list in your Agreement record.

3. In the Agreement Name field, enter the required name for the document or leave it as the name 
suggested by X-Author. The default name includes the agreement name, revision number, and 
version type. X-Author automatically saves the agreement in DOCX format.

4. Select the required watermark option.

When you select "Final - to be signed" as the check-in option, Create PDF attachment is 
automatically checked if you have the Comply System Property Auto Enable PDF for Final 
Docs enabled. For more information on Comply System Properties, refer to the Contract 
Management Administrator Guide on the Apttus Doc Portal.
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• Select Include Watermark, to add one to a non-final version. This option is available with the
 With Redlines and Without Redlines options.

• Include Watermark is automatically deselected (greyed out) if you are saving the document 
as Final - to be signed.

5. Select Reconcile Document to synchronize the Salesforce Agreement object fields with those that 
were updated in the document. See Reconciliation for more details.

6. Select Mark as private to enable the Private indicator for this agreement (only for use in custom 
implementations– see the Apttus Contract Management Administrator Guide for more information).

7. Click Finish to confirm check-in of the document. If you have selected the Reconcile option, you will 
see Save and Next button which takes you to the reconciliation page.

The document is checked in to Salesforce and the new document version is downloaded from the 
agreement record. Close the document you just checked in (no need to save) and load the newly 
downloaded document to continue working with the agreement, if necessary.

For information on enabling Contract Document Versioning and how it works, refer to the Contract 
Management Administrator Guide for the Salesforce platform.

Reconciliation

X-Author provides a reconciliation feature which enables changes made to smart fields in an agreement 
document, outside of the Salesforce/X-Author environment, to be reconciled with the data held in the 
Agreement record in Salesforce.

In a typical scenario where an agreement document is sent to an external party for negotiation, the external 
party will make changes to the document as part of the negotiation. If the changes to the document involve 
data belonging to the Agreement record, reconciliation provides the mechanism to ensure the values in the 
document and the Agreement record are reconciled.

To check in and reconcile smart fields and clauses

1. From the X-Author pane, click Finish to open the Check-In page.
2. Choose the Save Options for saving your document:

a. To check in the document with redlines, choose With Redlines.
b. To check in the document without redlines (clean), choose Without Redlines.
c. To check in the document as final, choose Final - to be signed.

3. Select the Reconcile checkbox and click Save & Next.

If the document already contains a watermark, the watermark will be removed instead 
when this option is chosen.



If there are any invalid fields in your agreement, a message is displayed and the check-in is not 
completed. Return to Doc Fields to validate fields and make corrected as needed.
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4. This page shows all the smart field with changed values that are available for reconciliation. Review 
the CLM Value and Current Value of the changed smart fields in your document and click Save & 
Next.

5. This page shows the changed smart clauses that are available for reconciliation. Expand a clause 
from the list to review the Original and Edited content of the clause.

6. Click Finish to check in the document with reconciliation.

Updating Fields from Contract Management
Update from CLM is an action located in the X-Author Contracts ribbon you can use to update smart fields 
and Readonly fields in your agreement document where fields have been updated in Apttus Contract 
Management since the document was generated. Update from CLM updates all header, 2nd, and 3rd level 
smart fields located in your document, including:

• Smart fields in the body of the agreement document.
• Smart fields in sections.
• Smart fields in tables or repeating datasets. Adding a new line item in Apttus Contract Management 

and updating will create a new row in the table.
• Smart fields in generated clauses.

To Update from Contract Management

1. Check out your agreement document and go to X-Author Contracts > Work tab and click the more 

icon .
2. In the menu, click Update from CLM to display a dialog showing all header-level fields in the 

document. Field values that have been changed on the Apttus CLM record are highlighted in red.

If you choose to check in the document without reconciling, changed smart field values will 
not be updated in the agreement record and changes to clauses will not be reflected in the 
Clauses related list in Contract Management. If you choose to check in the document with 
redlines, redlines and comments will be retained



Agreement documents cannot be reconciled with the agreement record as long as invalid values 
exist in the document for smart fields. Go to Doc Fields pane to perform a validation and correct 
any invalid field values.



• If you choose to update fields from Apttus CLM, all changed smart field values and 
Readonly field values will be updated. You cannot select only specific fields.

• Adding new line items to an Apttus CLM record and updating will only add a new row to the 
agreement document if a table exists containing those fields.

• Fields cannot be updated to or from an empty (null) value.
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3. Review the changed values and click Update to update the field values. If your agreement contains 
sections and tables, click Next to view fields contained in sections and tables.

4. Review the changed values and click Finish to update the field values.

You'll see a success message when the fields are updated in the agreement.

Opening Agreements in Contract Management
You can easily view the Agreement record associated with your document by choosing Open in CLM from 
X-Author.

To open an agreement in Contract Management

1. Connect to X-Author Contracts.
2. Open the agreement document for the agreement you want to view.
3. From the X-Author menu, hover over the menu icon   and click X-Author Contracts.
4. Under the X-Author Contracts pane, click the Work tab.

5. In the Work tab, click more icon   and select Open in CLM.

A separate browser window is opened and the agreement is loaded in Contract Management (You may be 
prompted to log in again to your Contract Management account in the browser).

Creating Offline Agreements
Offline Agreements can be created directly in X-Author Contracts, by taking a pre-existing Microsoft Word 
document that was created outside of CRM and has not previously been associated with an Agreement 
and checking it in. When you have a document without Apttus properties open in Microsoft Word and you 
can create a new agreement record by checking it in as an offline agreement.



X-Author Contracts for Cloud on Salesforce Spring 2019 User Guide

32 Copyright ©2011-2019 Apttus Corporation. All rights reserved.

To create an offline agreement

The document you want to use must not have previously been uploaded.

1. Open the document in Microsoft Word and connect to X-Author Contracts.
2. Select the X-Author Contracts option from the left-hand menu and go to Start > Create. The Create 

New Offline Agreement page is displayed.

3. In the Create New Offline Agreement window, enter the following details (fields marked with an 
asterisk are required):

Fields Description

Record Type* Select the Record Type from the picklist.

Name* Enter the agreement name.

Account* Select the Account from the picklist.

Primary Contact* Select the primary contact from the picklist.

Start Date Select the start date of the agreement from the date picker.
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Fields Description

End Date Select the end date of the agreement from the date picker.

4. Click Save. You will see a confirmation message.

A new agreement record is created in Apttus Contract Management and the document is attached to the 
Notes & Attachments related list.
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Importing Offline Agreements
Using X-Author Contracts you can import a document which has not previously been saved in CLM and 
attaches it to a pre-existing agreement record. Like creating a new agreement, when you choose to 
associate the document with a pre-existing agreement record, it is added to the Documents related list for 
that agreement. Unlike creating new offline agreement, importing an agreement offline does not create a 
new agreement record, but rather attaches your offline document to a pre-existing agreement record.

To import an offline agreement

1. With the document open in Microsoft Word, connect to X-Author Contracts.
2. Go to the X-Author Contracts pane >  Start > Search Agreements.
3. In the Search Agreements field enter the full or partial agreement name and click the search icon to 

locate your agreement.
4. from the search result select the agreement name and click Check In Offline.

Your document is checked in offline and you can download the checked-in version of the agreement 
document. You can view the checked in agreement from Documents related list of your agreement record 
in Contract Management. The imported agreement does not have a template associated with it.

Tracking Clauses in your Agreement Document
The Clauses related list on the Agreement record captures the clause activity for associated agreement 
documents during contract negotiation. You can open an agreement document in X-Author and make 
changes to it by inserting, modifying or deleting clauses. When you check-in that agreement document, 
new records are created in the Agreement Clauses Related List that reflect these changes. With each 
change made to the clauses, either from Playbook or to the new clause marked in an agreement document, 
you can see corresponding entries in the Agreement Clauses Related List of your agreement record in the 
Apttus CLM.

Agreement Clause activity is recorded in the related list during negotiation when you insert, modify or 
delete a clause in the initial session or a subsequent session. A session can be defined as the time 
between opening a document and checking it in. You can insert, modify or delete the content of a clause in 
an agreement document by doing any of the following:

• Inserting the clause from Playbook.
• Deleting a clause by marking it for deletion.

In the Agreement Clauses related list available for each agreement record, you can view the following 
changes in the agreement clauses as a result of the above mentioned actions with subsequent Check-In 
actions.

• For insert clause action, creates a single record with comment Inserted clause '<Clause Name>'.
• For any other action like deleting a clause, a single entry with clause number and no comments are 

created.
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The precedence for the value of clause's Action field is as follows,

User Action Action Column Status

If you insert a clause in the document Inserted clause '<Clause Name>'

If you mark a clause in a document Inserted clause '<Clause Name>'

If you edit the clause text, the value of the field inside a clause, 
and the user added comment

Modified

If you edit the clause text, and the value of the field inside a 
clause

Modified

If you edit the clause text and Add/ Update the comment Modified

If you edit the value of the field inside a clause FieldChangeOnly

After the agreement document is generated and checked out for the first time, a record is created 
in the Related List for all smart clauses present in the generated document with the Action as 
Original.
When you check in an agreement document as Final, the Action status of the smart clauses in the 
document is recorded as Final.
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Working with Templates
An Apttus template is a common set of sections, clauses, text, and placeholders for terms and conditions. 
Templates can be merged with structured data to generate agreements or proposals. Templates are stored 
within an Apttus template repository and are used to create quotes and contracts. An Apttus template can 
be termed as a blueprint or mold for creating distributable documents.

In a typical scenario where an agreement/proposal document is sent to an external party for negotiation, 
the external party makes changes to the document as part of the negotiation. The following sections 
describe the features you can use in X-Author when working with agreement templates.

• Opening Templates
• Creating New Templates
• Checking In Templates
• Clauses
• Fields
• Deleting Smart Elements Using Delete or Backspace Key
• Cloning a Template
• Template Expression Builder
• Setting Segments in Templates

Opening Templates
Using X-Author, you can open an agreement template from the repository and make changes to static text 
and other content in the document. When you are finished, you can check in the template and modify 
properties as needed (for example, changing which agreement types it is associated with).

To open a template

1. Open Microsoft Word and launch the X-Author add-in.
2. Log in to X-Author Contracts, as described here.
3. From X-Author Contracts pane, click the left-hand menu icon   and select X-Author Templates.
4. In the X-Author Templates pane, go to Start tab > Search > Search Templates.
5. Use the Search box to search for an agreement template by keyword. Click the filter icon   to 

expose drop-down menus that can help you to refine your search according to Template Type, 
Category, Subcategory, Locale, and Language.

6. From the list of documents, click the down arrow   to expand and view guidance for the template.
7. Click Open to download a copy of the template.
8. Check your Downloads folder for the file and open it in Word.

Your template will be opened. Edit text and other static content in your template. When you are finished, 
click Check-in to check-in your template.
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Creating New Templates
To get started with creating a new Agreement or Clause template in X-Author, you must first define the 
basic properties for your template.

To create a new template

1. Open an existing document or a blank document in Microsoft Word and log in to X-Author 
Contracts.

2. From X-Author Contracts pane, click the left-hand menu icon   and select X-Author Templates.
3. In the X-Author Template pane, go to Start > Create.
4. In the Create New Template pane enter the following details:

Field 
Name

Description

Type From the drop-down choose the type of template. You can choose from- Template, Clause, and 
Supporting Document.

Busines
s 
Object

Choose the the business object for your template from the drop-down. You can choose from- 
clm_Agreement, cpq_Quote, bil_Invoice, and bil_CreditMemo.

5. Click Save to confirm the template properties.

You can now work with your template.

Checking In Templates
A template is the blueprint using which an agreement is generated and clauses or supporting documents 
are created. Template outlines the content and the format of an agreement, clause, and a supporting 
document. After you create a new template or make changes to an existing template, you can check-in the 
template to update its contents in the CRM.

To check-in a template

1. Log into X-Author Contracts and select the X-Author Templates tab from the left-hand navigation 
menu.

2. In the X-Author Templates pane, click the Finish tab.
3. Under Check-in, enter the value of the following fields, (the fields marked with asterisk * are 

required)

Field Description

Name* Enter the name of the template.



X-Author Contracts for Cloud on Salesforce Spring 2019 User Guide

38 Copyright ©2011-2019 Apttus Corporation. All rights reserved.

Field Description

Agreement 
Types

From the drop-down you can select multiple Agreement types to associate with your 
template. The value of Agreement Types decides which templates are available at the time of 
agreement generation. If your Template's Agreement Type matches with the Agreement Type 
of your agreement record, you will see that template in list of available template at the time of 
document generation.

Category Choose the category from the drop-down. The categories are defined by the administrator, in 
Contract Management.

Subcategor
y

The subcategory is a dependent field. The Subcategories are populated, based on the value 
chosen for Category. The subcategories are defined by the administrator, in Contract 
Management.

Language Choose the default template language

Locale Select the locale from the drop-down.

Enable 
Formatting

Select this check box to enable locale formatting at the template level for this template.

Keywords* Enter comma-separated keywords to associate with the template. Keywords make it easier to 
search the templates.

Next 
Revision 
Date

Identify a date for the next revision of the template.

Description Enter a new description or modify the existing description for the template. Maximum of 255 
characters (an error will be thrown if this limit is exceeded).

Guidance Enter new guidance or modify existing guidance to help users determine the purpose of the 
template.

Activate Select the Active switch to 'On' to activate the template. You must activate a template to use 
it for generating an agreement document.

4. Click Check In.

Your template is checked in to Apttus Contract Management. A new template record is created for the 
template if this is the first check-in or modified if it already exists. A DOCX copy of the template is attached 
to the List of Templates in Contract Management.

X-Author Contracts for Cloud does not support localization for Date format, 
Currency format, and Number or Currency precision fields.
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Clauses
Clauses are modular blocks of text that are used frequently across multiple templates. You create clauses 
as described in Creating New Agreement Templates. After a clause is created, you can use Playbook to 
insert it into a template as static text.

The following sections explain how you can use clauses in your agreement template:

• Using Playbook for Templates
• About Template Clauses Menu
• Making Clauses Smart in a Template
• Making Clauses Condition-based in a Template
• Marking Clauses in a Template
• Refreshing Clauses in a Template

Using Playbook for Templates

Playbook is a library of clauses, or clause templates, that each contain modular blocks of contractual 
language that can be reused across multiple agreement templates. Playbook helps you to search for 
clauses or supporting documents that can be inserted into the template as inline text.

To insert a clause from Playbook into a template

1. In the X-Author Templates pane, go to Work > Playbook > Search Clauses.
2. In the Search Clauses field, click the search icon to list all the available clauses or enter a search 

string to search a specific clause.
3. You can also click clause filter icon   to get filtering options. You can filter the clause based on 

clause Category, Subcategory, Locale, Language, and Type.

You cannot use the Playbook to insert clauses unless the template you are working with has 
already been checked in at least once. If you are in the process of creating a new template, check 
in the template and open it again to start using Playbook.
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4. In your template document, place the cursor at the point of insertion.

5. Click a clause from the list to view the clause text and guidance. Select the clause from the 

Playbook pane, click more icon   next to the clause name and click Insert to insert the clause into 
your template as inline text.

You see a success message on successfully inserting a clause. The clause content is marked by a content 
control boundary in your template.

To delete a clause

Select the clause text in the template and press Delete. The selected clause text would be deleted from 
the template.

About Template Clauses Menu

The Template Clauses menu lists all the clauses and fields present in the currently opened template. The 
fields contained within a clause are shown hierarchically. From this menu you can take following actions on 
a clause or a field:

• Navigate to a clause in the template
• Mark a clause as smart
• Mark a field as smart
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• Mark a field as read only

To view a clause

1. Go to Work > Template Clauses tab.
2. Click on a clause name in the list. The document scrolls to highlight the selected clause in the 

template.

Newly marked clause are also displayed in the Template Clauses list.

Making Clauses Smart in a Template

You can use X-Author Contracts for Cloud to make a clause in your template smart. A standard 
contracting process begins with a generated document, and ends with a final agreement. In between the 
initial document and the final signed agreement, the document gets redlined and negotiated. Smart 
clauses help track the differences between different versions of the agreement document.

Smart clauses, like smart fields are parts of a contract that can be reconciled between versions of an 
agreement and noted in the agreement record. This can be used during negotiations when clauses are 
redlined. Clauses that have been changed will be reconciled when you choose the reconciliation option 
at Check-In. Clauses can only be smart in the context of a generated contract document.

In the process of negotiations, a contract may get redlined multiple times. During these redlines, a user 
may choose to accept the changes made to the contract. Smart Clauses provide visibility into the changes 
made in the contract document by allowing the user to view the changed clauses in at Check-in and when 
the clause change has been checked in, on the Agreement Clauses related list. 

When you use a template which has smartness attribute enabled for its clauses, the generated agreement 
document will have smart clauses that can be tracked.

To make a clause smart in a template

1. Open the template in X-Author Contracts.
2. Log in to X-Author Contracts and from the left-hand navigation select X-Author Templates.
3. In the X-Author Templates pane, go to Work >Template Clauses.

A Note on Agreement Documents and Templates
All generated agreement documents (as opposed to imported offline agreements) use document 
templates saved in Apttus Contract Management. These templates contain merge fields which, 
upon generation, pull Apttus field values from the agreement to create distributable documents.





X-Author Contracts for Cloud on Salesforce Spring 2019 User Guide

42 Copyright ©2011-2019 Apttus Corporation. All rights reserved.

4. The Template Clauses pane lists all the clauses present in your template. Select a clause from the 

list and click the gear icon next to the clause name .

5. In the Properties pane, slide the switch to turn on the Smart Clause attribute and click Ok.

Your template clause will now have smartness property. To remove the smartness property of a clause, you 
can slide the Smart Clause attribute switch to off position (greyed out).

Making Clauses Condition-based in a Template

You can use condition-based clauses in your template to make more customized and flexible agreement 
templates. The condition for the condition-based clauses can be simple or complex expressions that you 
can make using the expression builder. The clause conditions are evaluated at the time of agreement 
generation and the clause text is included in the generated document only if the associated condition 
resolves to True.

To add a condition to a clause

1. Open the template in X-Author Contracts.
2. Log in to X-Author Contracts and from the left-hand navigation select X-Author Templates.
3. In the X-Author Templates pane, go to Work > Template Clauses.
4. The Template Clauses pane lists all the clauses present in your template. Select a clause from the 

list and click the gear icon   next to the clause name.
5. In the Properties pane, click Add Condition to open the template expression builder.
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6. Create your condition expression in the Make Conditional page and click Add. For more information 
on how to create simple and complex condition expressions, refer to the Expression Builder section.

7. Click Ok to save the condition. The properties page now shows the condition that you created.

Your clause is made conditional and you will see a success message.

Marking Clauses in a Template

You can use the mark Clause menu to apply clause boundary and smartness property to a block of text. 
On generating a document, only the clauses marked as smart have the clause boundaries.

While constructing a template, you may have a block of text that you may not want in the playbook, but in 
the context of an agreement template (and later a contract), you would like to add the smartness property. 
Using Mark Clauses feature, you can add smartness propety to an inline text in the agreement template. 
Any clause formed from the Mark Clauses feature will, by default, have Smart Clause property turned on.

While marking a clause, you have to keepin mind the following points:

• Apttus recommends to only mark clauses which are not inserted from the Playbook. In other words, 
you cannot mark a clause as smart inside an existing clause record.

• After you mark a block of text as a clause, you cannot mark any other clause within the boundary of 
the marked clause.

To mark a clause in a template

1. Log in to X-Author Contracts and select X-Author Templates from the left-hand navigation.
2. Go to Start tab in the X-Author Templates pane and search and open a template.
3. Highlight the content (inline text) of the template that you want to mark as a clause.
4. After highlighting the content, go to Work Tab> Mark Clauses. If you cannot see the Mark Clauses

option in the Work tab, click the more option and select Mark Clauses.
5. In the Mark Clause form, specify the following details for marking a clause,

Field Description

Clause Name Enter a new name of the clause.

Category Select a category for your clause. The values of the categories 
are defined by your admin and help in filtering the clauses.

Subcategory Select a sub category for your clause. Options in the list will 
change based on the category you selected.

Exception Select a term exception record from the drop-down list to 
associate with your clause.

Risk Rating Select an appropriate risk rating for your clause. Valid values are:
• Green
• Red
• Yellow



X-Author Contracts for Cloud on Salesforce Spring 2019 User Guide

44 Copyright ©2011-2019 Apttus Corporation. All rights reserved.

Field Description

Materially Significant Select this check box if you want to make your clause materially 
significant.

6. Click Save.

Your clause is successfully marked and acquires content control border. After marking the clause you can 
go to Work > Template Clauses, to confirm that the marked clause is recognized in the document.

Refreshing Clauses in a Template

Refresh Clauses functionality allows you to keep your agreement template up to date. If the agreement 
contains clauses, and one clause has been changed but not published, this functionality can update the 
clause in the agreement template in context. The clauses having any of the following changes will appear in 
the Refresh Clauses list:

• Change in clause name, subcategory, or category
• Addition, deletion, or modification in clause content
• Change in the smart or merge fields

Prerequisite

Ensure that you have checked in the clause after editing it.

Restrictions

Nested clauses and clauses with repeat table or repeat section cannot be refreshed.

To refresh clauses in a template

1. In the X-Author Templates ribbon, click Refresh Clauses.
If the Template contains clauses with no changes, you will see a message stating, All clauses are 
up-to-date.
If the Template contains clauses with changes, you will receive a message showing which clauses 
need to be refreshed.

2. Click Refresh to update all of the clauses that are within your main Template. This displays the 
confirmation stating All clauses are refreshed successfully.

Fields
Fields that you insert in your template, or "merge fields" as they are sometimes called, represent the 
contractual terms and metadata from your Agreement record in Apttus Contract Management. When you 
generate a contract document, the values of the fields are reterieved from the agreement record and 
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populated in the document. As a template administrator, you are responsible for building your template to 
include fields, as static text, as read only fields or as content-control bound "smart" fields that can be 
changed and reconciled to the Agreement record during the negotiation process.

Following sections explain how you can use fields in your agreement template:

• Inserting Fields in a Template
• Making Fields Read Only in a Template
• Making Fields Smart in a Template
• Inserting Fields in a Template as a Table
• Inserting Fields in a Template as a Section

Inserting Fields in a Template

1. Open a template in X-Author Contracts.
2. From the left navigation pane, select X-Author Templates.
3. Go to Work tab> Insert Fields.
4. Place the cursor in the section of the template text, where you want to insert a field and click Insert 

New Fields.
5. In the Insert New Fields page, from the left column select the field's Object context (i.e., 

"Agreement"), then select object-qualified fields from the right column and click Submit.

The fields are inserted in the template. To view the inserted fields click Template Fields under the Work 
tab. Template Fields page shows the list of all the fields present in your current template. Select a field 
from the list to highlight it in the template document.

Making Fields Read Only in a Template

Read Only fields are fields with content control border and their values can be updated after document 
generation only using Update from CLM. These fields are different from smart fields and merge fields in 
that they are not inline like merge fields and their values cannot be edited like smart fields.

If you have generated an agreement document using a template containing the read-only fields and later 
want to update the values of the field without generating or regenerating another document, you can click 
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Update from CLM and the values of the read-only fields will be updated from the Contract Management 
agreement record. This is useful when you need to use the same agreement as a baseline document for 
creating another agreement with the same content but for a different agreement record. All the fields which 
are not marked as smart but need to be updated with the values from the new agreement record can be 
made read-only fields.

Read Only fields have the following characteristics:

• Any field can be made a read-only field or smart field but not both.
• Read-only fields cannot be made Smart.
• Read-only fields can only be defined in a template.
• The value of the read-only fields cannot be edited in the generated agreement document and can 

only be updated.
• Read Only fields show a content control boundary in the generated agreement documents.
• Fields in repeat table and repeat section can also be marked as Readonly.

To mark a field read-only

1. Insert the field into your template by following the steps in Inserting Fields into a Template.
2. From the X-Author Templates pane, go to Work tab > Template Fields. If you cannot see the 

Template Fields tab, click more 
 icon and select Template Fields.

3. The Template Fields page shows the list of all the fields present in your template. Search for and 
click the field name in the list to highlight it in the document.

4. Click the gear icon 
 adjacent to the selected field name to open the Properties page.

5. In the attributes list, turn on the Readonly Field switch and click Ok.

Your field will be made read-only.

Making Fields Smart in a Template

Smart fields are specialized fields that can retain the Apttus field definition even after the Merge Service 
generates the Agreement document. This feature helps for reconciling the document which is explained in 
detail in the Reconciliation section. Smart fields are intended for parts of an agreement that would normally 
be negotiated. Smart fields are usually represented by small chunks of text, such as dates, categories, and 
numeric values. Smart fields are not intended to hold large amounts of text–if necessary, use smart clauses 
instead.

Smart fields have the following limitations:
• Text Area data type fields and formula field for LongDate are not supported.
• You cannot mark Lookup fields as smart.
• Smart fields cannot be used in the headers or footers of agreement documents.
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To mark a field as Smart

1. Insert the field into your template by following the steps in Inserting Fields into a Template.
2. From the X-Author Templates pane, go to Work tab > Template Fields. If you cannot see the 

Template Fields tab, click more   icon and select Template Fields.
3. The Template Fields page shows the list of all the fields present in your template. Search for and 

click the field name in the list to highlight it in the document.
4. Click the gear icon   adjacent to the selected field name to open the Properties page.
5. In the attributes list turn on the Smart Field switch and click Ok.

Your field will be Smart.

Inserting Fields in a Template as a Table

You can insert fields as a table in your template and the inserted table is added as a repeat table. When 
template with repeat table is used to generate an agreement, the repeat table of a header row with 
inserted fields and their values in the preceding rows. 

1. Open a template in X-Author Contracts.
2. From the left navigation pane, select X-Author Templates.
3. Go to the Work tab.
4. Place the cursor in the section of the template text, where you want to insert a field and click Insert 

New Fields.
This displays the Insert Fields window.

5. From the left column select a line item object, such as Agreement Line Items. 
6. In the window to the right, hold command and select one or more fields from the list. Each field you 

select is displayed in a column in the table. 

7. Select the checkbox Insert as a table.
8. Click Submit. A Repeat table is inserted into your template with each field displayed as a separate 

column.
9. To search inserted fields:

a. Navigate to the Template Fields tab. This displays the Repeat Table (object name) and the 
fields in the repeat table.

b. Enter the field name in the search field and click the search icon ( ).
10. To make an inserted field smart field or readonly:

a. Click the gear icon (
 adjacent to the selected field name to open the Properties page.

If you want to turn off the smartness property of a field, turn off the Smart Field switch, under 
Properties.



Fields are inserted as columns in the table based on the order you select. Do not move your 
cursor when the fields are being inserted.



)
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b. In the attributes list, turn on the Smart Field or Readonly switch based on your requirement 
and click Ok.

11. To show or hide captions for a generated table:
a. Click the gear icon (

 adjacent to the Repeat Table.
b. In the Table Attributes section, turn on the Show Caption switch.

12. To select table formatting when no data is present:
a. Under the Table Display Attributes, click Format. This displays a drop-down menu. Select one 

of the following options based on your requirement.
i. To show table captions and one empty row, select Show captions and one empty row.
ii. To show captions only and no rows, select Show captions only.
iii. To remove the entire table from the generated document, select Remove whole table.

b. Click Ok.

Inserting Fields in a Template as a Section

You can insert fields as a section in your template and the inserted section will be added as a repeating 
section. This inserts each specified field on a new line when you select multiple fields (in the selected 
order). 

1. Open a template in X-Author Contracts.
2. From the left navigation pane, select X-Author Templates.
3. Go to the Work tab.
4. Place the cursor in the section of the template text, where you want to insert a field and click Insert 

New Fields.
This displays the Insert Fields window.

5. From the left column, select a line item object, such as Agreement Line Items. 
6. In the window to the right, hold command and select one or more fields from the list.  

7. Select the checkbox Insert as a Section.
8. Click Submit. A repeat section is inserted into your template with each field displayed one below the 

other.
9. To search inserted fields:

a. Navigate to the Template Fields tab. This displays the Repeat Section (object name) and the 
fields in the repeat section.

b. Enter the field name in the search field and click the search icon ( ).
10. To make an inserted field smart field or readonly:

a. Click the gear icon (
 adjacent to the selected field name to open the Properties page.

)

Fields inserted in a table cannot be made conditional.

Fields are inserted one below the other based on the order you select. Do not move your 
cursor when the fields are being inserted.



)
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b. In the attributes list, turn on the Smart Field or Readonly switch based on your requirement 
and click Ok.

11. To make inserted fields conditional, see Template Expression Builder.

Deleting Smart Elements Using Delete or Backspace Key
You can now use the Backspace or Delete key to delete clauses, fields, nested clauses, smart clauses, 
smart fields and read-only fields from an agreement document. Clauses or fields deleted from the 
document are recorded in the reconciliation screen as deleted. This feature improves the usability 
experience of X-Author Contracts.

Earlier smart elements like smart fields or smart clauses could be deleted only by marking them for deletion 
from the control panel and then reconciling them. This feature removes that limitation. Also, if you are not 
an Apttus user and do not have X-Author installed, you would still be able to delete smart elements from 
the agreement document. Additionally, earlier it was difficult to remove static text if it was in between two 
smart elements. That problem is solved with this feature.

Prerequisites

• To delete a smart element you must ensure that the value of the Comply System Property, 
UnlockSmartElements is set to True in Contract Management. Only then the smart elements 
become available for deletion.
For more information on how to configure the comply system property, refer to Contract 
Management on Salesforce Administrator Guide.

To delete a smart field, smart clause or repeat section

1. Select the smart element in the document. Highlight the text value of the field, clause, section or 
table with your mouse.

2. Press Delete or Backspace. This only deletes the field value but the content border remains.
3. Press Delete or Backspace again to completely delete the smart element. Now, the content border 

is also deleted.

OR

1. Identify the smart element in the document.

2. Click the vertical ellipsis icon   on the content control border of the element.
3. Press Delete or Backspace.

The content control border of the fields, as well as the field value, will be deleted.

To delete a repeat-table

1. Identify the smart table in the document.

2. Click the vertical ellipsis icon   on the content control border of the table.
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3. Press Delete or Backspace.

The cell values are deleted but the table remains with blank cells. When you delete a cell value within a 
table, the changes are shown as strikethrough in the reconcile smart fields in table screen. The new value 
column remains blank and the previous value is shown as strikethrough. However, this practice is not 
recommended because if you delete a cell in a repeat a table, you may see some issues during 
reconciliation.

To delete a read only field

1. Select the read only field in the document (Protection Mode= Full Access).
2. Press Delete or Backspace.

OR

1. Select the read only field in the document (Protection Mode= Insert Comments and Track 
Changes).

2. Press Delete or Backspace.
3. You will see a Microsoft Word's warning message, click Yes to continue with the delete operation.
4. Go to Microsoft Word ribbon and click Review tab.
5. Click Accept, to accept the delete changes. The content control of the read only field is deleted but 

the text value remains.
6. Select the text value and again press Delete or Backspace.
7. Repeat steps 3 and 4. You have to Accept the delete changes twice.

Now the complete read only field is deleted.

Best Practices and X-Author Contracts Behavior When Deleting Smart Elements or Read Only Fields

Smart elements can be deleted using the Del or Backspace key but, while doing it you must adhere to the 
following recommended best practices to avoid errors.

• Existing documents would not support delete using Delete or Backspace key unless they are 
regenerated from Contract Management or checked out in X-Author Contracts.

• Deleting with Backspace and Delete keys may not work with custom fields.
• Apttus recommends not to delete fields or smart elements in the following scenarios:

• If the fields are part of a nested clause, sections, X-Author Tables, Headers, or Footers.
• If the smart elements are part of a section with third level X-Author table.

When Document Protection is set to Full Access

• You must Accept or Reject each change in the Review tab of Microsoft Word, before checking in 
the document using X-Author Contracts.

• If you delete a field by selecting the field value text and pressing Delete or Backspace, hit 
Backspace or delete twice to remove the text and the content control border of the field. If you fail to 
do so, you'll see a validation error on reconciliation or while validating the fields using Validate Fields.

When Document Protection is set to Insert Comments and Track Changes
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• In Insert Comments and Track Changes protection mode, it is mandatory for you to first Accept or 
Reject the changes in the document from the Review tab of Microsoft Word before you perform any 
action from X-Author Contracts. Failing to do so will give you validation errors or unexpected 
behavior in X-Author Contracts. X-Author Contracts actions include performing Update from 
Salesforce, Checking in the document, reconciling the document, Preview Reconcile, and Validate 
Fields.

• You must remove the document protection by manually entering the password before you can delete 
smart elements as well as read-only fields from your document.

• If you select a content control and partially delete the text, the partial text would remain as static text.
• When you delete a smart field in the document and then open the control field, the Current Value

column of the Control Panel will show blank values for the deleted fields.
• When you delete a smart field which has multiple occurrences in the document, the smart field's 

occurrence index is not updated in the Control Panel unless you check-in the document. The index 
number helps identify which occurrence of the field you have deleted.

Cloning a Template
You can clone an existing template that you have opened to make a new copy of the template.

Pre-requisites:

• You must have an existing template opened in X-Author Contracts.

To clone a template from an existing template

1. Connect to X-Author Contracts and from the left navigation panel, select X-Author Templates.

2. In the X-Author Templates pane, go to the Work tab, click the more icon  and select Clone.
3. Click Clone on the X-Author Templates ribbon in Microsoft Word.
4. In the Clone Template page, change the name of the cloned template, to suit your requirements. By 

default, the cloned template name has 'Copy' added to the end of the original template name. For 
example, if you're cloning a template named Clause Agreement Template then the default name for 
the cloned template will be Clause Agreement Template Copy. You can edit the values of the other 
template properties too.

5. Click Save to save the cloned template in Contract Management.

Template Expression Builder
You can use a template expression builder to conditionally display content in your generated agreement 
document. You can write a conditional expression using the expression builder; this expression is 
evaluated to include or exclude the conditional content. The expression builder can be used with clauses, 
sections, segments or tables for their conditional rendering.

The expression builder has three main components or fields,
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• Fields are object fields. Fields lists all the available fields of the selected business object. It is a drop-
down list which shows the field names listed according to their hierarchy. Each expression condition 
requires the identification of the field control to which the condition will apply.

• Operator lists the logical operators for carrying out the logical operation.
• Value is the value of the object field selected earlier. The value finishes the expression and is used to 

determine whether the condition evaluates to True or False.

Adding Filter Logic

The Expression Builder allows you to Add Row to add more expression conditions, where two or more 
conditions are joined in the overall expression by the Filter Logic. In the absence of a filter logic, the default 
relationship between the rows is the Boolean operator AND.

You can add up to nine rows of condition expressions which can be used in a single expression using the 
filter logic. The supported filter logic operators are AND and OR. You can use parentheses for setting the 
precedence. For example, if you have five rows you can create a filter logic like, (((1 AND 3) OR (2 AND 
4)) AND 5). To add filter logic click Add Filter Logic and enter your logic in the field. Click Apply Logic to 
check whether your filter logic expression is correct. If your logic is incorrect, you'll see message in red.

Click Add to finalize your conditional expression.

Setting Segments in Templates
Set Segment feature allows you to set condition and style for the highlighted text in your agreement 
template. The condition for the segment's visibility can be set from the expression builder. The segment 
can consist of highlighted text, a clause, a group of text across clauses, or text with fields. You can 
leverage this feature to create a template that can show or hide different segments of text in the generated 
agreement based on the conditions set by you. The expression builder is fully integrated with the objects 
and fields in your Salesforce Org.
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To make a Segment Conditional in a template

1. In the X-Author Templates pane, go to Work tab, click the more options icon ( ) and select Set 
Segment.

2. Highlight a block of text in your template and click Set Conditional. This opens the Make Conditional
window which has the expression builder.

3. In the make Make Conditional window, you can create a conditional expression and also create a 
complex expression using logical operators between multiple rows of conditions. To create an 
expression you must enter the values of the following three fields:

Field 
Name

Description

Field Select the field which you want to set as the criteria for the condition. The Field drop-down 
shows the Agreement object and its fields from your Salesforce org. You must select a field 
name. The fields are listed and grouped according to their hierarchy.

Operat
or

You must select the logical operator from the drop-down. This forms the relationship between 
the Field and its Value.

Value Enter the value of the field name selected in the Field.

You can add multiple rows of conditions. To do this click Add Row and set your condition. Click Add 
Filter Logic to add a logical relation between multiple rows.

4. Click Add. 
You will see the success message and your segment will be added as Segment Conditional 
(Conditional) to the segments list in the Set Segment pane. Selecting the segment name from the 
list highlights that segment in the template document. 

5. To view or edit a segment condition, select the Segment Conditional (Conditional) from the 

segments list in the Set Segments pane and click the gear icon ( ) next to the segment name. 
This opens the Segment Conditional page and you can see the condition expression set for that 
segment. To edit the conditional, click the pencil icon ( ) next to Condition.
At the time of agreement generation, if your conditional's value evaluates to true, the associated 
segment is shown in the agreement document.

To delete a conditional segment in a template

1. Go to the Work tab > Set Segment tab in X-Author Templates.
2. Select the segment from the segment list. The selected segment is highlighted in the template.

3. Click the gear icon ( ) next to the segment name to open the Segment Conditional page.
4. Click Delete. You will see a confirmation message. Click Delete again.

Your segment is successfully deleted and the content control boundary of your segment is removed.
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To set a style for a segment in a template

1. In the X-Author Templates pane, go to the Work tab, click the more options icon ( ) and select Set 
Segment.

2. Highlight a block of text in your template and click Set Style. This opens the Select Styles window 
that lists custom styles.

3. Select a custom style or select the Show built-in styles checkbox and select a style.
4. Click Select. 

The segment is added as Segment Regular to the segments list in the Set Segment pane. Selecting 
the segment name from the list highlights that segment in the template document. 

5. To view or edit a segment style:
a. Select Segment Regular from the segments list in the Set Segments pane and click the 

gear icon ( ) next to the segment name. 
This opens the Segment Regular page with the segment style set for that segment. 

b. To edit the style, click the pencil icon ( ) next to Style. 
6. To add a segment condition, click Add Condition. This opens the Make Conditional window which 

has the expression builder. For more information, see To make a Segment Conditional in a template.
Segment Regular style segment changes to Segment Conditional after you add a condition. 
When you generate a document using a template with style segments, you can view different styles 
applied in the generated document.

To delete a style for a segment in a template

1. Go to the Work tab > Set Segment tab in X-Author Templates.
2. Select the segment from the segment list. The selected segment is highlighted in the template.

3. Click the gear icon ( ) next to Segment Regular to open the Segment Regular page.
4. Click Delete. You will see a confirmation message. Click Delete again.

Your segment is successfully deleted and the content control boundary of your segment is removed.
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Appendix
This section covers:

• Troubleshooting Manifest File Change Errors

Troubleshooting Manifest File Change Errors
Sometimes after upgrading your X-Author Contracts for Cloud application, you’re not able to access the 
new settings or configurations, or configurations show the old values. Also, if you change your X-Author 
Contracts manifest file to switch between different environments, the connections are not configured 
properly, and you get an ‘Undefined error’.

To overcome these configuration problems, after an upgrade or after switching the manifest file, you must 
clear your system’s cache. The following section describes the steps to clear cache on different Mac 
machines including the iMac and the MacBook.

Clearing cache from iMac (Desktop)

Pre-requisites

1. You must close the Microsoft Word application on your system.

To remove the Microsoft application cache

1. Go to Finder and enter the following path: ~/Library/Containers/com.Microsoft.OsfWeb Host/Data/
Library

2. Select the Caches folder and right-click.
3. Select Move to Trash and click OK.

After this open Microsoft Word and open the X-Author Contracts Add-in.

To remove Library cache

1. Go to Menu bar > Go> Home.
2. From the left navigation pane, select the logged in user.
3. Go to Library> Caches.
4. Right-click on Cache and select Move to Trash.

Clearing cache from Macbook

Pre-requisites

1. You must close the Microsoft Word application on your system.
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To remove the Microsoft application cache

1. Go to Menu Bar > Go > Go to Folder.
2. In the go to Folder dialog box enter the following path and click Go: ~/Library/Containers/

com.Microsoft.Word/data/Library/Caches/
3. In the Caches folder, select the folders starting with ‘com.microsoft..’
4. Right-click on the selected folder name and select Move to Trash.

After this open Microsoft Word and open the X-Author Contracts Add-in.

To remove Library cache

1. Go to Menu bar > Go > Home
2. From the left navigation pane, select the logged in user.
3. Go to Library > Caches
4. Right-click on Caches and select Move to Trash.
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distributed, or transmitted in any form or by any means, including photocopying, recording, or other 
electronic or mechanical methods, without the prior written consent of Apttus. All information contained 
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This document may describe certain features and functionality of software that Apttus makes available for 
use under a license agreement containing restrictions on use and disclosure and are protected by 
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to the programs. No other rights are granted to the U.S. Government.

Neither the software nor the documentation were developed or intended for use in any inherently 
dangerous applications, including applications that may create a risk of personal injury. If you use this 
software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-
safe, backup, redundancy, and other measures to ensure its safe use. Apttus and its affiliates disclaim any 
liability for any damages caused by use of this software or hardware in dangerous applications.

Apttus and X-Author are registered trademarks of Apttus and/or its affiliates.

The documentation and/or software may provide links to Web sites and access to content, products, and 
services from third parties. Apttus is not responsible for the availability of, or any content provided by third 
parties. You bear all risks associated with the use of such content. If you choose to purchase any products 
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responsible for: (a) the quality of third-party products or services; or (b) fulfilling any of the terms of the 
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to purchased products or services. Apttus is not responsible for any loss or damage of any sort that you 
may incur from dealing with any third party.

For additional resources and support, please visit https://community.apttus.com. 
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