This section describes step-by-step instructions to upgrade from Summer '20 and Spring '20 to Winter '20. 

You must install the Conga Base Library package first when you upgrade CPQ to Winter '20.

The Conga Push Upgrade is an automated tool that upgrades packages available in your Salesforce org (Production or Sandbox) to the latest versions. In addition, It ensures all the Conga published managed packages are on the latest versions for the registered orgs. To register your org for push upgrade, see Registering for Conga Push Upgrade.

Upgrading CPQ from Summer '20 to Winter '20

  1. Go to Setup > Installed Packages and ensure that your current Salesforce org has the following Summer '20 packages installed.

    Product

    Latest Certified Version

    (Version Name | Version Number)

    Apttus Approvals Management (New)
    (Required if you are using Approvals)
    11.1.0161 | 11.161

    Apttus Base Library (New)

    (Required if you are using Apttus Configuration & Pricing)

    1.1.93 | 1.93

    Apttus Configuration & Pricing (New)

    12.1.1787 | 12.1787

    Summer 2020

    Apttus Contract Management (New)11.1.0547 | 11.547
    Apttus Contract-Configuration Integration (New)
    (Required if you are using CLM)
    12.1.0136 | 12.136
    Apttus CPQ API (New)12.1.0104 | 12.104
    Apttus CPQ Admin (New)
    (Required if you are using CPQ Admin Console)
    12.1.61 | 12.61
    Apttus CPQ Approvals Management (New)
    (Required if you are using Approvals on CPQ objects)
    11.1.0018 | 11.18
    Apttus Deal Maximizer Setup (New)
    (Required if you are using Deal Maximizer)
    7.5.0050 | 7.50
    Apttus Order Management1.0.0000 | 1.0
    Apttus Promotion Management 
    (Required if you are using Promotions)
    1.0.0000 | 1.0
    Apttus Proposal Management (New)
    (Required if you are using Proposal Management)
    10.1.0221 | 10.221
    Apttus Quote/Proposal Approvals Management6.5.0004 | 6.4
    Apttus Quote/Proposal-Asset Integration6.5.0014 | 6.14

    Apttus Quote/Proposal-Contract Integration (New)

    9.1.0063 | 9.63
    Apttus Quote/Proposal-Configuration Integration (New)
    (Required if you are using CPQ and Proposal Management)
    12.1.0332 | 12.332
  2. Ensure that you have the following packages and dependent packages to upgrade to Winter '20. These packages are required to utilize the new features and enhancements of Winter '20. These are the minimum required versions; later versions are also supported.

    Product

    Latest Certified Version

    (Version Name | Version Number)

    Conga Approvals (New)
    (Required if you are using Approvals)
    11.2.0190 | 11.190

    Conga Base Library (New)

    (Required if you are using Conga Configuration & Pricing)

    1.2.123 | 1.123

    Conga Configuration & Pricing (New)

    12.2.1787 | 12.1839

    Winter '20

    Conga Contract Lifecycle Management (New)11.2.0582 | 11.582
    Conga CLM Configuration Integration (New)
    (Required if you are using CLM)
    12.2.0146 | 12.146
    Conga CPQ Api  (New)12.2.0111 | 12.111
    Conga CPQ Setup  (New)
    (Required if you are using CPQ Admin Console)
    12.2.83 | 12.83
    Conga CPQ Approvals  (New)
    (Required if you are using Approvals on CPQ objects)
    11.2.0019 | 11.19
    Conga Deal Maximizer Setup
    (Required if you are using Deal Maximizer)
    7.5.0050 | 7.50
    Conga Order Management1.0.0000 | 1.0
    Conga Promotions
    (Required if you are using Promotions)
    1.0.0000 | 1.0
    Conga Quote Management (New)
    (Required if you are using Proposal Management)
    10.2.0227 | 10.227
    Conga Quote Approvals6.5.0004 | 6.4
    Conga Quote Asset Integration6.5.0014 | 6.14

    Conga Quote CLM Integration (New)

    9.2.0065 | 9.65
    Conga Quote Configuration Integration (New)
    (Required if you are using CPQ and Proposal Management)
    12.2.0334 | 12.334
  3. Perform the upgrade. The upgrade procedure is the same as the installation procedure. For detailed information on installing CPQ managed packages, see Installing CPQ Packages.
  4. After the upgrade is complete, perform the post-upgrade tasks.

Upgrading CPQ from Spring '20 to Winter '20

  1. Go to Setup > Installed Packages and ensure that your current Salesforce org has the following Spring '20 packages installed.

    Product

    Latest Certified Version

    (Version Name | Version Number)

    Apttus Approvals Management (New)
    (Required if you are using Approvals)
    11.0.0114 | 11.114

    Apttus Base Library (New)

    (Required if you are using Apttus Configuration & Pricing)

    1.0.40 | 1.40

    Mandatory package to be installed in the Spring 2020 release.

    Apttus Configuration & Pricing (New)

    12.0.1719 | 12.1719

    Spring 2020

    Apttus Contract Management (New)11.0.0518 | 11.518
    Apttus Contract-Configuration Integration (New)
    (Required if you are using CLM)
    12.0.0130 | 12.130
    Apttus CPQ API (New)12.0.0100 | 12.100
    Apttus CPQ Admin (New)
    (Required if you are using CPQ Admin Console)
    12.0.54 | 12.54
    Apttus CPQ Approvals Management (New)
    (Required if you are using Approvals on CPQ objects)
    11.0.0016 | 11.16
    Apttus Deal Maximizer Setup (New)
    (Required if you are using Deal Maximizer)
    7.5.0046 | 7.46
    Apttus Order Management1.0.0000 | 1.0
    Apttus Promotion Management 
    (Required if you are using Promotions)
    1.0.0000 | 1.0
    Apttus Proposal Management (New)
    (Required if you are using Proposal Management)
    10.0.0210 | 10.210
    Apttus Quote/Proposal Approvals Management6.5.0004 | 6.4
    Apttus Quote/Proposal-Asset Integration6.5.0014 | 6.14

    Apttus Quote/Proposal-Contract Integration (New)

    9.0.0055 | 9.55
    Apttus Quote/Proposal-Configuration Integration (New)
    (Required if you are using CPQ and Proposal Management)
    12.0.0324 | 12.324
  2. Ensure that you have the following packages and dependent packages to upgrade to Winter '20. These packages are required to utilize the new features and enhancements of Winter '20. These are the minimum required versions; later versions are also supported.

    Product

    Latest Certified Version

    (Version Name | Version Number)

    Conga Approvals (New)
    (Required if you are using Approvals)
    11.2.0190 | 11.190

    Conga Base Library (New)

    (Required if you are using Conga Configuration & Pricing)

    1.2.123 | 1.123

    Conga Configuration & Pricing (New)

    12.2.1787 | 12.1839

    Winter '20

    Conga Contract Lifecycle Management (New)11.2.0582 | 11.582
    Conga CLM Configuration Integration (New)
    (Required if you are using CLM)
    12.2.0146 | 12.146
    Conga CPQ Api  (New)12.2.0111 | 12.111
    Conga CPQ Setup  (New)
    (Required if you are using CPQ Admin Console)
    12.2.83 | 12.83
    Conga CPQ Approvals  (New)
    (Required if you are using Approvals on CPQ objects)
    11.2.0019 | 11.19
    Conga Deal Maximizer Setup
    (Required if you are using Deal Maximizer)
    7.5.0050 | 7.50
    Conga Order Management1.0.0000 | 1.0
    Conga Promotions
    (Required if you are using Promotions)
    1.0.0000 | 1.0
    Conga Quote Management (New)
    (Required if you are using Proposal Management)
    10.2.0227 | 10.227
    Conga Quote Approvals6.5.0004 | 6.4
    Conga Quote Asset Integration6.5.0014 | 6.14

    Conga Quote CLM Integration (New)

    9.2.0065 | 9.65
    Conga Quote Configuration Integration (New)
    (Required if you are using CPQ and Proposal Management)
    12.2.0334 | 12.334
  3. Perform the upgrade. The upgrade procedure is the same as the installation procedure. For detailed information on installing CPQ managed packages, see Installing CPQ Packages.
  4. After the upgrade is complete, perform the post-upgrade tasks.