16 Adding Products Shows Console Error
Error
The following errors are displayed in the console when you add products:
No such column 'apttus_cmconfig__agreementid__c' on entity 'Apttus_Config2__LineItem__c'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.
Or
Visualforce Remoting Exception: No such column 'YourField_c' on entity 'Apttus_Config2LineItemc'. If you are attempting to use a custom field, be sure to append the '_c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names
Or
No such column 'YourField_c' on entity 'Apttus_Config2LineItemc'. If you are attempting to use a custom field, be sure to append the '_c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.
Cause
This happens when there is a wrong filed name in configuration.
What to do
Solution 1
Perform the following steps to resolve the error:
- Go to
- Click Manage. Edit Setting.
- Remove the field that appears in the error.
- Click Save.
Solution 2
Perform the following steps to resolve the error:
- Go to
- Click Manage.
- Look for the criteria that has yourField_c value added.
Solution 3
Perform the following steps to resolve the error:
- Go to
- Check all criteria. There might be the field added somewhere on any criteria.
Solution 4
Perform the following steps to resolve the error:
- Clear all data cache entries.